Sign in with LinkedIn Subscribe on YouTube

View Shopping Cart
Color-Logic | Special Effects for Print | Support | FAQs

FX-Viewer System Requirements

IMPORTANT: FX-Viewer IS NOT COMPATIBLE with the latest Retina display iMacs. Click here for more information

FX-Viewer has the following minimum system requirements:

- Operating System: Mac OS X 10.5 or higher
- GPU: ATI X1600 or newer, or NVIDIA GeForce 6 or newer
- Intel CPUs only

Any machine originally shipping with 10.5 or higher will be capable of running the application. Upgraded machine will require a GPU roughly 6 years old or newer. Machine without a GPU, that is, "integrated graphics" ("Intel graphics"), as found in older MacBooks, are not supported. Newer integrated graphics machines will actually run the software, but with very slow performance. For MacBooks, this means the Model Identifier at a minimum is, MacBook4,1.

In addition GhostScript must be installed in order for FX-Viewer to function, you can download it at

If you are installing FX-Viewer  on a Mac with OS X 10.7 or greater, your system may state that it requires XQuartz-2.7.4 or greater. If it states this, you can find that at After installing, log off the user account and then log back in before using FX-Viewer.