View Shopping Cart

Design Suite System Requirements

The Color-Logic Design Suite is compatible with Adobe Indesign, Illustrator, and Photoshop versions CS6 upwards, on both Mac and Windows platforms.

Please see Adobe system hardware requirements on their site at:

InDesign
Illustrator
Photoshop

For FX-Viewer system requirements Click here for more information